3D Modeling for Archaeological Documentation
using the JVRP Method to record archaeological excavations with millimeter-accuracy

JVRP White Papers in Archaeological Technology

Adam B. Prins

This document is available for download at www.jezreelvalleyregionalproject.com/3d-modeling.html
Advances in 3D modeling technology, and the availability of inexpensive, easily-learnable processing software has enabled archaeological fieldwork to be carried out at a significantly higher resolution, with far greater accuracy than previously possible. Structure from Motion technology (SfM) is central to these developments, democratizing the ability to produce precise, photo-realistic, scalable models of the world and everything in it, using only standard photographs.

This guide will provide a brief technical explanation of the underlying technology, but will primarily act as a practical field guide that can be used to quickly acquire the skills necessary to produce georeferenced, millimeter accurate 3D models in the field on an archaeological excavation.

The instructions that follow are based on the JVRP Method, a field methodology developed over years of experimentation on Jezreel Valley Regional Project excavations. It will quickly become apparent however, that whatever terminology and project-specific conventions one may be accustomed to will have little bearing on the applications and benefits of these methods. The workflow that follows has been developed in the field and extensively tested on active excavations, so various examples from JVRP projects will be used throughout to illustrate the process itself, as well to demonstrate the archival, publication-quality products that it enables.

1. Introduction
2. Setup
   a. What you need
   b. Getting ready in the field
3. Photography
   a. Camera settings
   b. Taking the photos properly
4. Spatial referencing
   a. Control point surveying
   b. Outputting coordinates
5. Software processing
   a. Photoscan UI overview
   b. Add and align photos
   c. Optimize cameras
   d. Detect control point targets
   e. Build dense point cloud
   f. Build mesh
   g. Build texture
   h. Model cleanup
6. Outputs
   a. Build and export orthophoto
   b. Build and export DEM
   c. Export 3D PDF
7. Step-by-step review
1. Introduction

The majority of archaeologists, both historically and today, rely on rudimentary field documentation methods that have not changed much over the last century and do not live up to the methodologies of other field-based disciplines. These techniques, familiar to anyone who has studied archaeology, are based upon using a pencil, paper, and tape measure for recording most information about an excavation, including architecture, loci/contexts, in situ assemblages, and small finds. Generally culminating in manual two-dimensional line drawings, even the most skilled draftsperson can only produce a plan that is a general representation, not an objective record of reality.

The traditional method results in a record that is typically accurate to within 8-10 centimeters, which, for reference, is about as large as a medium-sized pebble. Many excavations dig in 4 x 4 meter squares, so relatively-speaking, 10 centimeters represents a significant error. Additionally, the aesthetics of a plan are subconsciously interpreted by the illustrator as they attempt to draw what they see. When drawing architecture, for example, the artist will often unintentionally draw what they expect or want to see, by making small seemingly-insignificant adjustments to stones that propagate out into a relatively idealized form.

The JVRP Method\(^1\) addresses these concerns by using Structure from Motion technology (SfM) (Ullman 1976) to document archaeological features and materials in the field. SfM functions by sifting through a series of overlapping photos taken from a variety of consistent angles, and finding points between them that match. After turning the matched points into a point cloud, the software interpolates the geometry between the points and builds a model that is accurately scaled to itself. Since the model is generated from 2D photographs, the software combines them into a single photorealistic texture which is draped over the geometry, resulting in a strikingly accurate and objective depiction of reality. For further accuracy and additional uses, control points in the scene are measured using a total station or GPS and used to georeference the model, which places it in its real-world location, allowing for easy integration with GIS software to produce overall site-plans and conduct a variety of spatial analyses.

Compared to the centimeters of error found in traditional methods, SfM models offer significantly improved accuracy, typically between 6-10 millimeters. A dataset with such insignificant error ultimately allows for highly accurate and precise outputs, including 2D orthophotos from which traditional architectural plans can be produced by tracing walls and features, as well as a number of 3D deliverables that can be tailored to specific research needs and for archival posterity.

The JVRP Method was developed to record every locus in the field. The benefits of this comprehensive documentation include the automatic production of architectural plans and profiles, top-plans, sections, and a complete visual record of the field archaeologist’s decision-making process. The informed reader can ultimately decide the degree to which this methodology is implemented, but this guide was written with locus-by-locus recording in mind.

---

\(^1\) The Jezreel Valley Regional Project (JVRP) is a long-term, multi-disciplinary survey and excavation project investigating the history of human activity in the Jezreel Valley from the Paleolithic through the Ottoman period. This project strives for a total history of the region using the tools and theoretical approaches of such disciplines as archaeology, anthropology, geography, history, ethnography, and the natural sciences, within an organizational framework provided by landscape archaeology.

The JVRP Method was developed by the author with the collaboration of Michael Ashley (Codifi, Inc.), Robert Homsher (W.F. Albright Institute of Archaeological Research and Harvard University), Matthew J. Adams (W.F. Albright Institute of Archaeological Research), Melissa Cradic (University of California, Berkeley), Mario Martin (Tel Aviv University), and Nick Kraus (Yale University). It would not have been possible without the patience and enthusiasm of dig staff and field school students alike.
2a. Setup

What you need

The most important piece of equipment when seeking high quality models is the **digital camera** used to take the photographs. An 8 megapixel or better Digital Single Lens Reflex (DSLR) that can capture photos in the camera RAW file format is ideal, and while any camera will produce results, keep in mind that the quality of the resulting models correspond to the quality of their constituent photos.

A consistent **light source** is essential for the production of clean evenly-lit models. Whether it’s the sun at a particular time of day, a diffused flash, or a tarp to make shade, the entire scene should be lit uniformly to reduce unwanted shadows.

If you intend to produce properly-scaled, georeferenced images for GIS and spatial analysis, you'll need access to a **Total Station** or **GPS** and physical **photogrammetry targets** for indicating the location of spatial reference points. If using GPS, it will need to be differential GPS (dGPS) or Real-time Kinematic (RTK), as standard consumer devices do not yet offer the accuracy necessary to produce useful models. When choosing the physical targets there are a number of options that will suffice, from beer bottle caps to professional computer-readable photogrammetry targets. This choice is up to the preference of the technician, although throughout JVRP field testing, the best results came from photogrammetry targets manufactured by [Cultural Heritage Imaging](https://www.culturalheritageimaging.com). These particular targets are coded (similar to QR barcodes), and thus integrate with the processing software for automatic detection, saving a significant amount time and enhancing accuracy.

For controlled color consistency, it is recommended that a **color checker** be added somewhere in the scene. This adds known color information, allowing for normalization across all the photos which produces even more realistic models.

For processing, it is recommended that you use a powerful **computer**, particularly with a high-end Graphics Processing Unit (GPU), multi-cored processor, and plenty of memory. Although a faster computer will produce models more quickly, older computers can certainly still be used, as long as the technician doesn’t mind waiting—perhaps a long time—the results will be the same.

The JVRP Method uses **Agisoft’s Photoscan Professional** software. The software developers offer a free trial as well as reasonably-priced academic licensing, with valuable updates included for the foreseeable future. There are two versions of the software: standard and professional. While the underlying technology is the same, the professional version includes essential features (georeferencing, target detection, more outputs) absent from the standard version, and is thus the better choice for those following this guide. The software is available on all major computing platforms (Windows, Mac OS X, and Linux).
2b. Setup
Getting ready in the field

Prior to taking photographs, there is some setup that will help keep things running smoothly. Firstly, since the JVRP Method results in a photorealistic 3D model, the scene should be as clean as possible. What you see is what you get, so if the section isn’t straight or there’s a pile of sediment in the corner, those things will end up in the model.

Secondly, in order to georeference the eventual model, the photos must contain physical control points that can be associated with spatial coordinates from the total station or GPS. The JVRP prefers the photogrammetry targets made by Cultural Heritage Imaging (CHI) (see figure 1), as they are durable, built-for-purpose, and integrate with the processing software to allow for automatic target detection.

When documenting a 4x4 meter excavation square, place between 4-10 control points. These points do not need to be obtrusive or even in the actual excavation area itself, they simply need to be visible in most of the photos. Once the model is referenced the sticks can be cropped out, leaving a perfectly georeferenced model. The meter-long CHI bars contain three coded targets, so for a typical square, you’ll need 2 or 3 bars. Figure 2 depicts good control point placement.

Now keep in mind that the control points, which at this stage do not yet have spatial data associated with them, must not move at all once you’ve begun taking photos. If one of the bars is moved even a centimeter between one photo and the next, you will be unable to georeference the model using that bar. Ensure that the people around you are aware that these bars cannot be touched. If someone accidentally bumps one of the bars, the best thing to do is discard the preceding photos and start the series again. If one of the bars was bumped out of place but you were unaware, don’t worry, it will be obvious when attempting to georeference the model. There is a workaround for this problem that will be addressed in greater detail in the software processing section, but it diminishes the accuracy of your model, so it is best to avoid this issue if at all possible.
3a. Photography

Camera settings

In general, you'll want your camera set to **aperture priority mode**, usually indicated by an A or Av on the settings dial, depending on the brand of your camera. Aperture priority mode allows you to manually adjust the size of the aperture, which controls how much light reaches the sensor, while letting the camera adjust the other settings to match. The size of the aperture is measured in F-stops, which also affect your photos’ depth of field, the visual plane that is most in focus. In general, F8 or F11 works well, but this setting will depend on the amount of light and complexity of the scene and should be manually adjusted prior to starting the photo sequence. Other camera modes will work, and if aperture priority mode seems scary, then you can stick to automatic, but for the purpose of this guide, we will assume that the camera is always set to aperture priority.

3b. Photography

Taking the photos properly

This section is crucial, and some of it may be counterintuitive to the uninitiated.

What we're doing here is building a 3D model from 2D photos, so the quality of the individual photos is of paramount importance. High quality photos will almost always result in a high quality model and, of course the reverse is also true.

Essentials to keep in mind while shooting: there should be approximately 60-80% overlap from one photo to the next. The photos should be taken from the **same height and angle**, and should be taken at **regular intervals** with the camera held in **portrait position**, that is, vertically.

When beginning the photo sequence, it is important to think about the subject of the scene. Most of the time this is simply a 4 x 4 meter excavation square, so the positions of the cameras are straightforward. For standard documentation of a square, you'll want to take approximately 50 photos in total: **10 from each baulk**, **1 oblique angle from each corner**, and **1 additional** photo from a slightly higher **central perspective** on each baulk. In figure 3, the blue rectangles represent the position of the camera lens, and you can see that the camera is held at the same height and orientation across each baulk. The height of the camera will depend on the photographer, and as such consistency is key to this step.
4a. Spatial referencing
Control point surveying

After the photographs are taken, the control point should still be on the ground in their original position. We are now ready to record the coordinates of each point. The CHI bars contain coded targets which the processing software can automatically detect. In order to detect them properly it helps to initially record them in a certain way. In the total station, the points for each 3D modelling session should be stored in a separate job and the recorded point ID should match the number next the physical target. The numbers themselves are unimportant and were chosen by CHI to minimize duplicates across multiple sets of bars. So if the physical target is point 27, then the point in the total station should be recorded as target 27. This means that when using a Leica total station, the operator must manually type the word target and then the corresponding number in order to minimize adjustments after the fact. The benefits of this step will become clear in the proceeding sections.

While recording the targets, the prism staff must be held perfectly level, directly on the center of the target (see figure 4). It is especially important to keep the prism level for these points as even a small error at this stage will propagate out into significant inaccuracy. Communication between the person holding the staff and the total station operator is key. The point should only be recorded once the holder is satisfied that the prism is perfectly level.

4b. Spatial referencing
Outputting coordinates

Once the targets’ coordinates are recorded, the total station operator exports the points as a standard comma separated value (.csv) file without headings. The file should look like the figure to the right, with the formatting as follows:

```
target #,x,y,z
```

![Figure 4](image_url)
5a. Software processing

Photoscan UI overview

Now that you have a set of photos and a text file with total station points, we can start building the model.

Agisoft Photoscan has a simple interface, and we only need to know about a few of its capabilities to accomplish our task. The interface consists of four main panes: the **Workspace** pane, **Photos** pane, the **Reference** pane, and the **Model** pane.

The bulk of the functions used to build the model are located under the Workflow menu, and the greyed out functions will become enabled as the preceding steps are completed.

5b. Software processing

Add and align photos

Before doing any processing, we must first import the photos to Photoscan.

1. Go to the **Workflow** menu and select **Add Photos**, or click on the **Add Photos button** in the toolbar.
2. Navigate to the folder containing your photos, select the entire photo range, and click **Open**.

This brings you back to the main interface, where you’ll see the photos added to Chunk 1. Don’t worry about this terminology, it doesn’t concern us.

3. **Save** your model file, by selecting **File > Save**.

4. Next we’ll start the actual processing by selecting **Align Photos** from the **Workflow menu**. This will bring up a dialog box where some of the default options need to be adjusted.

5. In the **Align Photos dialog**, click to arrow next to **Advanced** to expand all the options.

6. Select **Medium** accuracy. Medium should be sufficient for most purposes, but if you are unhappy with the results, you can always reprocess the model at the High setting.

When set at Medium, Photoscan downsamples the photos to half their original resolution while matching points, which significantly decreases the overall processing time. The Low setting downsamples to a quarter of the original resolution, and the Lowest setting downsamples to an eighth of the original resolution. Low and Lowest should generally be avoided, as they result in mediocre models. The Highest setting should also be avoided, as it upsamples the photos by a factor of 4, and is intended for research purposes and not practical use.
7. Set the **Pair preselection** option to **Generic**. This decreases processing time by initially matching points between photos at a lower resolution and then again at a higher setting as needed.

8. Under **Advanced**, the **Key point limit** should be set to **60000** and the **Tie point limit** should be set to between **20000** and **40000**. These settings influence how many points the software will match, and have produced the best results in our experiments. These particular parameters can have a significant impact on the quality of the model, but also the speed at which the model is built. So if your computer is struggling, some trial and error with decreasing these settings may reduce the amount of necessary processing time.

9. Click **OK** to start the alignment.

10. When finished, **save** your model file, by selecting **File > Save**.
5c. Software processing

Optimize cameras

Now that the photos are aligned, you're left with a sparse point cloud. This point cloud represents the bare minimum number of matched points based on the accuracy you selected.

At this point, we need to optimize the camera locations in order to properly recognize the control point targets later on.

1. Select **Optimize cameras** from the **Tools menu**.

   This will bring up a dialog box with many options, make your selections match the screenshot below.

2. Click **OK**.

3. When finished, **save** your model file, by selecting **File > Save**.
4. After optimizing, we need to tell the software in which part of the world we are working. Click the **Settings button** on the **Reference pane** toolbar.

5. Select the **Coordinate System** drop-down menu and select **More...** (Israel and other local coordinate systems are not in the options by default, we need to add it).

6. Click the dropdown arrow next to **Projected Coordinate Systems** and scroll down to **Israel 1993**. Click the dropdown next to Israel 1993 and select **Israel 1993 / Israeli TM Grid**. If you are working elsewhere in the world, simply select the relevant coordinate system.

7. Click **OK** to geographically relocate the model to Israel.
8. Now that the model is in the correct region, set the **Tie point accuracy (pix)** to 0.1.

9. Click **OK**.

10. To update the camera locations, we need to run **Optimize Cameras** again.

11. When finished, **save** your model file, by selecting **File > Save**.
5d. Software processing
Detect control point targets

Now that we have an optimized sparse point cloud, Photoscan can automatically detect the photogrammetry targets that we placed in the scene.

1. From the Tools menu, select **Markers > Detect Markers**.
2. Click **OK** with the default settings selected.

You will now see small blue flags on the locations where the total station points were recorded, and a list of the targets without coordinates in the **Reference pane**.

These points do not yet have spatial data associated with them, so we must now **import** the .csv file that we exported from the total station in section 4b.

3. While still on the **Reference pane**, click the **Import button** on the toolbar.
4. Navigate to the location where you saved the .csv file from the total station, select it, and click **Open**.

5. If the points were properly exported from the total station, this will bring up a dialog to confirm that the target numbers and headings match.

   **Easting** = X coordinate  
   **Northing** = Y coordinate  
   **Altitude** = Z coordinate

   Verify that the **Coordinate System** is set to **Israel 1993 / Israeli TM Grid**. And that **Delimiter** is set to **Comma**. The other settings can be left at their default values.

6. Click **OK**.

7. **Save** your model file, by selecting **File > Save**.

   The targets are now associated with the real-world coordinates that you recorded with the Total Station.

8. Now we need to run **Optimize Cameras** again.
5e. Software processing

*Build dense point cloud*

In order to produce a photorealistic, accurate model, we need to add more points to the cloud.

1. Select **Build Dense Cloud** from the **Workflow menu**.

   The quality settings for this step are similar to the initial alignment, except that the Ultra High quality option samples the photos at their original resolution, High quality samples the photos at half their original resolution, and so on.

2. Select **Medium** from the drop down menu. This setting is generally sufficient for a high quality and accurate model. As noted previously, you can always choose to re-run this step at a higher quality setting.

3. Click **OK** to start building the dense point cloud.

4. When finished, **save** your model file, by selecting **File > Save**.
Once this step has finished, the model will start to look realistic, but we’re not quite done yet.

It should be noted that this solid surface view and the previous dense cloud view will not be automatically displayed by Photoscan, they are depicted here for illustrative purposes and can be accessed by selecting the relevant button on the main toolbar.

5f. Software processing

Build mesh

Now that we have a dense point cloud, we can build the geometry that connects the points into a solid surface.

1. From the Workflow menu, select Build Mesh.
2. In the Build Mesh dialog, the default options as below will result in a high quality model
3. Click OK to build the mesh.
At this point we have geometry and solid surface, all that’s left is adding the photorealistic texture.

5g. Software processing

Build texture

1. From the Workflow menu select Build Texture.
2. In the dialog box that opens, change the Texture size/count to 8192.
3. Under the Advanced drop-down, check the Enable color correction box if your photos have significantly variable lighting or ambient coloring, otherwise leave this unchecked, as it significantly increases processing time.
4. Leave the other options at their default values.
The other options in the **Mapping mode** dropdown can make a significant difference in the quality of the resulting texture, so experiment with the other settings if you are not satisfied with the model’s texture. This step does not take long to process.

**5h. Software processing**

*Model cleanup*

Now that the processing is complete, you can **clean up** the model by cropping out the extraneous areas.

Use the **Rectangle selection** tool on the main toolbar to select and delete as necessary.
6a. Outputs
Build and export orthophoto

The model is now fully built and georeferenced. In order to utilize its data, we need to export the model to a more common and compatible format. All GIS and geospatial analysis software can interpret GeoTIFF files, a raster image format with embedded spatial information that allows it to be automatically placed in its proper location on a map. We'll use this as a default export format.

Before outputting a TIFF file, Photoscan first needs to recompile the composite texture information as well as the spatial data from the photogrammetry targets. This is a fast step and does not require much user input.

1. From the Workflow menu, select Build Orthomosaic.
2. In the Build Orthomosaic dialog, leave the default values as they are and click OK.
3. From the File menu, select Export Orthomosaic > Export JPEG/TIFF/PNG.
4. In the Export Orthomosaic dialog, leave the default options as they are and click OK.
5. If you wish to produce a smaller sized output file, you can decrease the Pixel size parameter to a reasonable resolution. This will directly impact the file size.
6. Browse to the location where you would like to save your orthophoto, name the TIFF file, and click Save.

This GeoTIFF file can now be brought into GIS software and used for drawing traditional-looking stone-by-stone architectural plans and for spatial analysis.
6b. Outputs

*Build and export DEM*

In order to conduct certain types of spatial analysis on the completed model, a Digital Elevation Model (DEM) is crucial. This format can be brought into GIS software and its production also generates the information necessary to take spot elevations directly from within Photoscan. This additional layer of information is extremely convenient for checking locus elevations, elevations of architectural elements and artifacts, and makes it so that the field archaeologist doesn’t have to worry about ensuring the proper elevations were manually measured in the field—they are always available after the fact, as long as the element is visible in the model.

1. From the **Workflow menu**, select **Build DEM**.
2. In the **Build DEM** dialog, leave the options at their default values and click **OK**.
3. The DEM is now built and can be viewed from the **Workspace pane** by clicking on the **arrow** next to **Chunk 1**, and double-clicking on **DEM**.

The DEM will now be viewable in the main window, shaded based on elevation, and a legend will be visible indicating said elevations. When you hover the cursor over any point on the DEM, the X, Y, and Z coordinates will appear in the bottom right corner. The third value, Z, is the elevation of the point directly under your cursor. These numbers will change in real time based on the position of the cursor.
If you wish to permanently record the elevation of a specific point for later reference, you can drop a point on the DEM and measure its spatial values.

1. While viewing the DEM, click the **Draw Point** button on the main toolbar.
2. Click once on the spot you wish to measure to drop a marker.
3. Right click on the marker and select **Measure**.
4. This will bring up a dialog box containing the X, Y, and Z coordinates of your point.
5. If you wish you export the DEM for use in GIS software, select **Export DEM** and then **Export TIFF/BIL/XYZ** from the **File** menu.
6. In the resulting dialog box, leave the parameters at their default values and click **Export**.
6c. Outputs

Export 3D PDF

If you wish to preserve the dimensionality of your model, you can also choose to export the model as a 3D PDF. Anyone with the free Adobe Reader or paid Adobe Acrobat can natively open the normal PDF file and fully manipulate it as if it were still in Photoscan. This is valuable for sharing excavation results and to include those who cannot come to site in person.

1. To export a 3D PDF, select **Export Model** from the **File menu**
2. In the dialog box that appears, select **Adobe PDF (*.pdf)** from the **Save as type** drop-down menu.
3. Name your PDF file and click **Save**.

This will bring up the **Export Model - PDF** dialog box. The options can be left at their default values, as shown in the figure to the right.

4. Click **OK** to export the PDF file.

You can now open the exported PDF file in Adobe Reader or Acrobat and manipulate it normally.
Step-by-step review

In the field

1. Place between **6-10 control points** in or around the square.

2. With the camera held **vertically**, take approximately **10 photos from each baulk**, from the same height and angle, **an additional oblique photo** from each corner, and **one more from the center of each baulk** from a **higher position** than the first round.

3. **Record the coordinates** of the control points using a **Total Station**.

   point naming convention: 
   
   `target #,x,y,z`

4. Export the coordinates from the total station as a **.csv file** with no headings.
Step-by-step review
_in Photoscan_

Save your model file after each step!

1. Workflow menu > Add Photos
2. Workflow menu > Align Photos
3. Tools menu > Optimize camera alignment
4. Reference pane > Settings button
5. Set projected coordinate system to Israel 1993 / Israeli TM Grid (or the coordinate system relevant to your project's location)
6. Set Tie point accuracy (pix) to .1
7. Tools menu > Optimize camera alignment
8. Tools menu > Detect Markers
9. Reference Pane > Import button
10. Select .csv file exported from Total Station
11. Tools menu > Optimize camera alignment
12. Workflow menu > Build Dense Point Cloud
13. Workflow menu > Build Mesh
14. Workflow menu > Build Texture
15. Crop and cleanup model with Selection Tools
16. Workflow menu > Build Orthomosaic
17. File menu > Export Orthomosaic
18. Workflow menu > Build DEM
References and Resources

Agisoft's Photoscan Professional
Cultural Heritage Imaging